Covercard

Incident Report for HIN Status Page

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 13:02 CET

Update

We are continuing to investigate this issue.
Posted Feb 25, 2026 - 09:29 CET

Investigating

Unfortunately, covercard.hin.ch is currently unavailable.


Start time: 25 Februar 2026 – 09:20

Thank you for your patience.
Posted Feb 25, 2026 - 09:28 CET
This incident affected: HIN geschützte Anwendungen | Applications protégées HIN (Covercard Service).