Partial Outage HIN Webmail

Incident Report for HIN Status Page

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 15:45 CEST

Investigating

We are currently experiencing an issue with the printing function in Webmail.

Our technical teams are investigating the issue and working to resolve it as quickly as possible.

We will provide further updates as soon as more information is available.

We apologize for the inconvenience and thank you for your patience.

Start: 14.07.2026 - 14:00
Posted Jul 14, 2026 - 15:00 CEST
This incident affected: HIN Mail (HIN Webmail).