HIN Webmail Outage

Incident Report for HIN Status Page

Resolved

This incident has been resolved.
Posted May 17, 2026 - 18:25 CEST

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 09:23 CEST

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 09:22 CEST

Investigating

There is currently an partial outage affecting HIN Webmail.

We are working flat out to resolve the issue.

Start: 15.05.2026 – 09:00
Posted May 15, 2026 - 09:13 CEST
This incident affected: HIN Mail (HIN Webmail).