HIN Sign Outage

Incident Report for HIN Status Page

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 14:30 CEST

Investigating

Documents cannot currently be signed via HIN Sign.
Our supplier is already working to resolve the issue.

Start: 3 August 2026, 14:10
Posted Aug 03, 2026 - 14:18 CEST
This incident affected: HIN Sign.