HIN Global emails cannot be opened.

Incident Report for HIN Statusseite

Resolved

This incident has been resolved.
Posted Aug 11, 2025 - 08:01 CEST

Investigating

HIN Global emails cannot be opened.

The SMS code verification process is currently impaired.

We are working hard to resolve the issue.

Start: 11 August 2025 – 7:30
Posted Aug 11, 2025 - 07:55 CEST
This incident affected: HIN Mail (HIN Mail Global).