HIN SEAL Mails cannot be opened

Incident Report for HIN Status Page

Resolved

This incident has been resolved.
Posted May 20, 2026 - 09:01 CEST

Investigating

Currently HIN Mail Seals cannot be opened.

Issue start: 20.05.2026 - 08:00
Posted May 20, 2026 - 08:28 CEST
This incident affected: HIN Mail (HIN Mail-SEAL (HIN Mail an Nichtmitglieder)).