PDF preview issues in HIN Sign

Incident Report for HIN Status Page

Resolved

This incident has been resolved.
Posted May 21, 2026 - 15:35 CEST

Update

We are continuing to investigate this issue.
Posted May 21, 2026 - 15:35 CEST

Update

We are continuing to investigate this issue.
Posted May 21, 2026 - 15:33 CEST

Update

We are continuing to investigate this issue.
Posted May 21, 2026 - 15:33 CEST

Investigating

We are currently experiencing issues with the display of PDF documents in the preview within HIN Sign.

The issue appears to affect scanned PDFs that use specific compressed image formats (JBIG2 / CCITT Fax) — common in scans from copiers and document management systems.

During the signing process, affected PDF files may appear unreadable or only partially rendered in the preview. The signing functionality itself remains fully operational. At this time, the issue is limited to the PDF preview during the signature workflow.

Our technology partner is already working to resolve the issue.
We apologize for the inconvenience.
Posted May 21, 2026 - 10:23 CEST
This incident affected: HIN Sign.